В Laravel 5.8 признаны устаревшими хелперы для работы со строками и массивами

Ромчик
0

В Laravel 5.8 признаны устаревшими хелперы для работы со строками и массивами. Вместо функций необходимо использовать классы: Illuminate\Support\Arr и \Illuminate\Support\Str. Например:


// Устаревшее

array_add($array, $key, $value);

// Необходимо использовать

Arr::add($array, $key, $value);

В версии 5.8 хелперы будут еще доступны, а вот с версии 5.9 они исчезнут. Но Тейлор заявил, что возможно хелперы полностью не исчезнут, просто из засунут в Composer пакет laravel/helper.

Оригинал новости.

Понравилась статья? Поделись с друзьями.
  • Add to favorites
  • Добавить ВКонтакте заметку об этой странице
  • Twitter
  • Facebook
  • Мой Мир
  • LiveJournal
  • Одноклассники
  • Блог Я.ру
  • MySpace
  • FriendFeed
  • В закладки Google
  • Google Buzz
  • Яндекс.Закладки
  • Reddit
  • StumbleUpon
  • Technorati
  • del.icio.us
  • БобрДобр
  • LinkedIn
  • Memori.ru
  • Сто закладок
  • Blogger

©2012-2019 По всем вопросам обращайтесь через форму обратной связиПолитика конфиденциальности

Яндекс.Метрика